股票軟件通達信精品指標公式-買進持有指標源碼

公式源碼:

VAR1:=MA(CLOSE,5);

VAR2:=MA(CLOSE,10);

VAR3:=MA(CLOSE,30);

VAR4:=MA(CLOSE,60);

VAR5:=EMA(COST(85),7);

VAR6:=EMA(COST(15),7);

VAR7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);

VAR8:=INTPART(VAR7*100)/100;

VAR9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);

VARA:=INTPART(VAR9*100)/100;

VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);

VARC:=INTPART(VARB*100)/100;

VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);

VARE:=EMA(CLOSE,5)-EMA(CLOSE,10);

VARF:=EMA(VARD,9);

放空段: IF(VARD>VARF,VARF,VARE),COLOR00FF00,LINETHICK2;

持股段: IF(VARD< VARF,VARF,VARE),COLORRED,LINETHICK2;

VAR10:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;

VAR11:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;

VAR12:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;

VAR13:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;

VAR14:=REF(VARF,1);

VAR15:=VARF;

VAR16:=VAR15-VAR14;

VAR17:=REF(VARD,1);

VAR18:=VARD;

VAR19:=VAR18-VAR17;

VAR1A:=OPEN;

VAR1B:=CLOSE;

變盤點: IF(VAR1A<=VAR1 AND VAR1A<=VAR2 AND VAR1A<=VAR3 AND VAR1B>=VAR1 AND VAR1B>=VARC AND VAR16>0 AND VAR19>0,0.5,0), STICK,COLORWHITE;

VAR1C:=IF(CROSS(VARD,VARF) AND VARD<0 AND VARF<-0.2 AND VAR11>45 AND VAR16>0,0.3,0);

買進1: IF(VAR1C,0.5,0),COLORYELLOW;

DRAWICON(買進1,0.5,1);

VAR1D:=(2*CLOSE+HIGH+LOW)/4;

VAR1E:=LLV(LOW,34);

VAR1F:=HHV(HIGH,34);

VAR20:=EMA((VAR1D-VAR1E)/(VAR1F-VAR1E)*100,13);

VAR21:=EMA(0.667*REF(VAR20,1)+0.333*VAR20,2);

VAR22:=REF(CLOSE,1);

VAR23:=SMA(MAX(CLOSE-VAR22,0),6,1)/SMA(ABS(CLOSE-VAR22),6,1)*100;

賣出: IF(CROSS(84,VAR23),0.5,0),COLOR00FF00;

DRAWICON(賣出,0.5,2);

持倉:0,COLORFF00FF;

空倉:0,COLORGREEN;

{持倉:}STICKLINE(VAR20>VAR21,0,-0.02,10,1),COLORFF00FF;

{空倉:}STICKLINE(VAR20< VAR21,0,-0.02,10,1),COLORGREEN;

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,請讀者僅作參考,并自行核實相關內容。如發現有害或侵權內容,請聯系郵箱:jubao@pinlue.com,我們將在第一時間進行核實處理。

http://image95.pinlue.com/image/48.jpg
分享
評論
首頁
暖暖高清在线观看视频桃花社区视频在线观看播放