股票軟件通達信精品指標公式-阿木資金E源碼

公式源碼:

A:=LARGEINTRDVOL*10000/FINANCE(7);

B:=LARGEOUTTRDVOL*10000/FINANCE(7);

A1:=SUM(A,3);

B1:=SUM(B,3);

A2:DMA(A1,21);

B2:DMA(B1,21);

DRAWBAND(A2,RGB(255,0,0),B2,RGB(0,30,200));

H1:HHV(A2,8);

STICKLINE(A2-H1<0,H1,A2,0,-1);

H2:CONST(REF(H1,5)),DOTLINE;

H4:CONST(REF(H1,20)),COLORLIGRAY,DOTLINE;

DRAWBAND(A2,65,H2,RGB(30,0,80));

DRAWBAND(A2,255,B2,RGB(0,210,250));

機構:(L2_VOL(0,0) - L2_VOL(0,1))*10000/FINANCE(7),NODRAW,COLORRED;

大戶:(L2_VOL(1,0) - L2_VOL(1,1))*10000/FINANCE(7),NODRAW,COLORMAGENTA;

中戶:(L2_VOL(2,0) - L2_VOL(2,1))*10000/FINANCE(7),NODRAW,COLORLIGREEN;

散戶:(L2_VOL(3,0) - L2_VOL(3,1))*10000/FINANCE(7),NODRAW,COLORLIBLUE;

主力:機構+大戶,NODRAW,COLORYELLOW;

STICKLINE(主力>0,H2,H2+主力,2,1)COLORYELLOW;

STICKLINE(主力<0,H2,H2+(主力),2,1)COLORLIBLUE;

K:=機構+大戶+中戶+散戶;

STICKLINE(機構>0,H2,H2+2*(ABS(散戶)+ABS(中戶)+ABS(大戶)+ABS(機構)),1,0),COLORRED;

STICKLINE(機構<0,H2,H2+2*(ABS(散戶)+ABS(中戶)+ABS(大戶)+ABS(機構)),1,0),COLORBLUE;

STICKLINE(大戶>0,H2,H2+2*(ABS(散戶)+ABS(中戶)+ABS(大戶)),1,0),COLORLIMAGENTA;

STICKLINE(大戶<0,H2,H2+2*(ABS(散戶)+ABS(中戶)+ABS(大戶)),1,0),COLORGREEN;

STICKLINE(中戶>0,H2,H2+2*(ABS(散戶)+ABS(中戶)),1,0),COLORLIRED;

STICKLINE(中戶<0,H2,H2+2*(ABS(散戶)+ABS(中戶)),1,0),COLORLIGREEN;

STICKLINE(散戶>0,H2,H2+2*散戶,1,0),COLORLIGRAY;

STICKLINE(散戶<0,H2,H2+2*ABS(散戶),1,0),COLORLIBLUE;

{STICKLINE(大戶>0,H2,H2+大戶*3,1,0),COLORMAGENTA;

STICKLINE(大戶<0,H2,H2+ABS(大戶)*3,1,0),COLORGREEN;

STICKLINE(機構>0,H2,H2+機構*3,1,0),COLORRED;

STICKLINE(機構<0,H2,H2+ABS(機構)*3,1,0),COLORCYAN;}

DRAWICON(CROSS(EMA(C,13)-EMA(C,34)>=EMA(EMA(C,13)-EMA(C,34),12),0.5),A2,34);

DRAWICON(CROSS(EMA(EMA(C,13)-EMA(C,34),12)>EMA(C,13)-EMA(C,34),0.5),A2,35);

DRAWICON(H2<H4 AND CROSS(A2,H2) AND A2>B2,H2,23);

IF(H2>H4,1,0);

DRAWICON(H2>H4 AND CROSS(A2,H4) AND A2>B2,H4,23);

DRAWICON(FILTER(A2=HHV(A2,23),1),A2,1);

DRAWICON(FILTER(B2=LLV(B2,23),2),B2,2);

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,請讀者僅作參考,并自行核實相關內容。如發現有害或侵權內容,請聯系郵箱:jubao@pinlue.com,我們將在第一時間進行核實處理。

http://image95.pinlue.com/image/90.jpg
分享
評論
首頁
暖暖高清在线观看视频桃花社区视频在线观看播放